Impatica Knowledgebase

KB-000212: I have an Intel-based Mac. Will Impatica for PowerPoint Mac OS X edition run on this platform?

Impatica for PowerPoint v 3.0.0 will not run on Intel-based Macs but the current Impatica for PowerPoint Mac OS X Edition v4 release will run on the Intel-based Mac platform.

Version 4 of Impatica for PowerPoint Mac OS X Edition requires a version 4 code. If you do not have a version 4 code, please visit our website to check your upgrade eligibility.

http://www.impatica.com/download/upgrade.html

If you have any questions please contact support@impatica.com

Would you like to...

Print this page Print this page

Email this page Email this page

Post a comment Post a comment

Subscribe me

Add to favoritesAdd to favorites

User Opinions (1 vote)

100% thumbs up 0% thumbs down

How would you rate this answer?

Helpful
Not helpful
Thank you for rating this answer.