Impatica Knowledgebase

KB-000128: We just migrated to a new Windows Server (e.g. 2003 or newer) and the JAR file can no longer open the IMP file. Any ideas?

You must declare the MIME types within IIS on Windows Server 2003+.

In order to set the MIME types to get Impatica content to play from a Windows 2003+ server please do the following:

1. Go to the IIS Control Panel (IIS Manager).
2.
Select in the left-hand panel your local computer name - Don't expand it, simply select the computer.
3. Right-click the local computer and select "Properties" from the pop-up menu.
4. This will launch the local computer's property window.
5. At the bottom of the property window is a button that reads "MIME types".
6. Once you select this option you have the opportunity to Add, Edit or Remove MIME types.

7. Select to add a MIME type.
8. In the Extension area type "imp".
a. Set the MIME type to "application/octet-stream".
9. In the Extension area type "imv".
a. Set the MIME type to "application/octet-stream".
10. In the Extension area type "jar".
a. Set the MIME type to "application/java-archive".
11. In the Extension area type "class".
a. Set the MIME type to "application/java-class".


Restart of the server may be required.

With these changes the Windows-based IIS server should be able to serve up the files without issue.

Would you like to...

Print this page Print this page

Email this page Email this page

Post a comment Post a comment

Subscribe me

Add to favoritesAdd to favorites

User Opinions (1 vote)

0% thumbs up 100% thumbs down

How would you rate this answer?

Helpful
Not helpful
Thank you for rating this answer.